Installing the Building Design Suite

Apr 14, 2012

Autodesk Building Design Suite Ultimate 2013

I have been waiting to install the latest Autodesk 2013 software because I wanted to install the Suite. The stand alone 2013 products have been out for a few weeks but the Suites (at least the Building Design Suite that I was interested in) only just posted on Thursday this week. I have a few comments on the experience that I would like to share. My main reason for preferring to install the Suite over the individual products is that it is simpler in several ways:

But alas, there is always a downside. So here were some issues that I ran into:

Once finally downloaded, I could begin the install. The waiting is not over. When you first double-click that EXE to “install” what you are really doing is unzipping. This takes ANOTHER couple hours. (The first time failed, because as i noted above, I had to re-download a few of the archives, never very fun). But when I had everything downloaded, and fired it up, well, the progress bar started and then I hit the first snag:

A bunch of Red error messages started to appear. Issues about QTO and some of its files… At first I watched and wonder how this would affect me, but then decided to cancel and investigate. As you may know, when you unzip the archive, it suggests your C drive in a folder called Autodesk. I usually just change this to D:\Autodesk and leave the rest of the path alone. This time, I was using a folder called _Autodesk Software. This is because I had a few other folders starting with “A” and I recentely renamed my Autodesk folder to ensure that it was first on the list. No issues with BDS 2012 when I did this. But I suspected that due to the length of the path in the red error message above that I was hitting some sort of file name limit. So, I moved the older back to D:\Autodesk and tried again. This time it worked! no errors.

Proud of my cleverness, I let the install continue. Well, the progress bar chugged along for quite a long time and just when it was at the end… it reset itself to the beginning! WTF? Well, remember that message area of the unzip dialog that showed the red error messages for QTO above? Well upon further inspection I noted that it had just completed part 1 of the archive. It was now on to archive 2. <sigh> there are six more parts…

One thing I forgot to mention is that the evening before, when I was downloading, I changed the power settings on my system so that it would not go to sleep and cancel the download. Nothing more frustrating than that. So I left my settings set this way during the unzip too. Trouble is, I had leave for a client meeting and it was only half done. Now, I should have known better than to start this before an appointment. My original plan was to unzip the archive, then cancel and when I came back later, it would be ready to go. I had over an hour before the meeting, so THEORETICALLY it should have been fine… Famous last words…

Well, I had already invested this much time, I did not want to start over. So I just grabbed my machine and took it with me in the car and let it continue unzipping  during my hour commute. I still had the power settings set to not go to sleep. Surly it would be done by the time I arrived? Again my plan would be to simply cancel, and then later run the install from the unzipped folder.

Well, you know what happened next. My screen froze, I had to hard shut down when I got to the client and now I was possibly going to have to unzip all over again. Well in this I got lucky. I had apparently finished unzipping BEFORE it crashed. Luck smiled on me this one time.

 

On to the Install!

So I went into the D:\Autodesk folder, located the Setup.exe file and fired it up. The installer appeared, I configured all of my choices, (selected almost everything, left off a few items) and clicked install. Away it went. There was something like 59 items.

59 of 59 left to install

52 of 59 left to install

40 of 59 left to install

28 of 59 left to install

Icons were appearing on my desktop, it was cranking away and somewhere around 22 items left, an error dialog appears saying something about the installer’s not being able to find some file needed for QTO again. OK, well let me take a look. I manually browse to the location that it says in Windows Explorer and what do I find? Well there’s the offending file. Soooo…

Now get this, there are only two buttons in the dialog that has now stalled the installation. They are “Retry” and “Cancel.” (kind of reminds me of a Revit warning… ouch).

Are you kidding me? You know what Retry did. So feeling defeated, I click Cancel, figuring I don’t REALLY need QTO right now. But wait, it gets better. Do you know what Cancel does? Wait for it…

It REVERSES the ENTIRE installation. That’s right, all of the 37 successfully installed programs up to this point uninstall themselves as I hopelessly watch. Bye Revit, bye AutoCAD, Bye Navis… Unbelievable.

OK, so after some choice words. I try again. This time I will only select Revit, Max Design, AutoCAD Arch, MEP and a few other items. No QTO this time. Off it goes again. After getting much further, somewhere in the teens this time, maybe 15 of XX left, it displays the SAME type of error. This time on some sample project. A SAMPLE PROJECT!!! Really???

So, not about to let it uninstall again and feeling thoroughly frustrated, I click cancel and then kill my machine. I figured, well, if I hard shut down (extreme I know) it won’t be able to uninstall all the programs. Maybe not the most thought out plan, but hey, I was frustrated.

After re-starting my machine, I tested each program. Revit worked, AutoCAD Arch worked, Max Design, Inventor, they all worked.

AutoCAD MEP… totally hosed. (Couldn’t get that lucky could I?)

The REAL issue

OK, well, what about the other programs that did not install? I still did not have QTO, Design Review, Infrastructure Modeler and a few other misc items. So, I tried to install just one at a time. Design Review, no problem. The others not so much. Then it dawned on me. Those errors I got all looked similar.

The issue is the length of the file and folder names. When I downloaded Building Design Suite 2012, the folder of the unzipped file was named: Autodesk_BDS_Ultimate_2012_English_Win_64bit. This time, the folder was named: Autodesk_Building_Design_Suite_Ultimate_2013_English_Win_32-64bit.

Much longer because they wrote out “Building Design Suite” and because it includes the extra 32 bit descriptor in there. I renamed this folder to change the Building_Design_Suite part to just BDS and voila! All products install without fail!

After all of that grief. It is the length of the stinking folder names that caused the trouble. This is really something that should have been tested Autodesk. A few years ago I had a similarly bad experience trying to get my Adobe CS to install. I contacted their tech support and they were no help. Nothing sours the initial experience of a new (and expensive) piece of software like not being able to quickly and easily install it. I am not blaming anyone for the time it takes to download, it is what it is. But folder name lengths are something that can EASILY be tested for and adjusted.

Good grief. Anyhow, I hope that this L O N G post helps someone out there.

So here is a summary of what you want to do:

Good luck!

 

Share

17 Responses to Installing the Building Design Suite

  1. Pingback: Building Design Suite 2013 | BD Mackey Consulting | The Revit Geek Blog

  2. Alan Skipper says:

    I don’t think I’ll bother then!!!!!!!!

    • Paul F. Aubin says:

      Well, just be sure the paths are short enough before you start and it should be fine. Had I done that in the first place, I am sure I could have saved myself much grief.

  3. Sara Hill says:

    Thank you so much for being willing to discover these problems early on – and share the solutions with us!

  4. Daniel says:

    By the way did you notice how many languages are now listed under: other English…

    If I had know at school that German and French are just ‘other English’ I would have done much better at these subjects.

  5. Gary Brinkley says:

    I tried the download from AUTODESK Subscription yesterday
    and it took all morning before “as you said” everything failed.
    I received late yesterday the USB stick and this morning after two trys
    (both having failed)trying to install from it
    I’m just not clear on your steps to take on the “archives and stopping the installer”.
    Sorry I’m beyond frustrated and needing help with this.
    You can reply directly to my E-mail and avoid everyone else having to
    read through this again if you like.
    Thanks in advance

  6. Ken Fisher says:

    Thanks Paul. Your pointing out bumps in the road lets us change our tire pressure before we go down that road.

    My biggest problem with BDS is how the license cascades in a network license environment.

  7. Pingback: Let Paul try it! « microsolresources

  8. Brian Mackey says:

    Paul I just noticed that in my Revit the Navisworks exporter and switchback did not get installed, is it the same for you?

    http://bdmackeyconsulting.com/building-design-suite-2013-bug/

    • Paul F. Aubin says:

      I don’t see it either. I will have to investigate further, but it will have to be later. I am off to a client. Thanks.

  9. There are similar path length problems when creating network deployments of Building Design Suite 2012. I too discovered the limitations the hard way, installing the suites for customers. Often, the customer’s have some predetermined folder structure on their servers, and there will be a “starting” folder location to create the network deployments. First attempts at the very lengthy BDSP installations would fail, an hour and a half or two hours into the deployment creation, always on Showcase or Sketchbook Designer, complaining “Error writing a file… verify that you have access to that directory”.

    Working with Autodesk tech support, they confirmed the installer was hitting a path length limit, but they could not tell me what the longest path was in BDSP. So, I tried shortening the start path 2 times, the 3rd tried was the charm (about 4 hours later) and finally worked. I now try to use the shortest possible path and folder name when creating deployments. I expressed my concern with Autodesk, that the names of materials in both Showcase and Sketchbook Designer read like sentences and are unnecessarily long.

    There are many issues with installing the suites, particularly the Ultimate suites, such as the fact the installer is so huge that it often fails. On an Autodesk blog site a fix was published, whereby one needs to copy the installer local (takes 1 hr – 1.5 hrs) then do a setup.ini swapping method to create deployments for half the products, and repeat to create deployment for the other products. Takes about 1 whole day to set up BDSU deployment and then actually install to a computer.

    http://upandready.typepad.com/up_and_ready/2011/07/autodesk-suites-failure-creating-deployment-for-autodesk-building-design-suite-ultimate-2012.html

  10. Pingback: Building Design Suite Install update | BD Mackey Consulting | The Revit Geek Blog

  11. Ted says:

    I used to lambaste Autodesk for the shortcomings of AutoCAD. Did that for a long time, however in ’07 I rethought that and found peace with the software. I’ve been using it since 1986.

    …but idiocy is always like Whack-A-Mole. It disappeared here? You can count on it rearing its ugly head there…

    They needed to address deployments even back in the ’90s. Looks like they have done a really bad job of it – and now I’m fighting this 9-headed Hydra as well.

    • Paul F. Aubin says:

      Hi Ted:
      This is an older post. In fairness to Autodesk, the last two releases have installed much more smoothly for me. I suppose I should have come back and posted that here some time ago. shame on me for not keeping the post active. Thank you for your comments.

Leave a Reply to Mark McDonough Cancel reply

Your email address will not be published. Required fields are marked *

Categories

Archives

Subscribe to

Subscribe

 

PaulAubin.com